Tech Requirements

Technical requirements for using Blackboard.

The minimum requirements for Blackboard are:

  • A computer and an internet connection.
  • A current web browser ( Internet Explorer, Firefox, Safari, or Chrome). FireFox works best with Blackboard 9.  See the supported browsers and OSs in the linked site below.
    Please note that Blackboard does not work well with AOL's web browser. If you are using AOL to connect to the internet you will need to minimize AOL and open any of the above mentioned browser separately.
  • The latest Java plug-in. Java is required to use Virtual Classroom, online Chat and file drag-and-drop for instructors.
  • Enable Javascript and cookies for your browser. 
  • Your York email account. (Blackboard uses your York email, or other CUNY campus email if you prefer. It is the University requirement that no personal email is used for official and academic communication.)
  • Software applications recommended or required by your instructor (ex: Word, Excel).
  • A speaker or head-phone if the course site has audio and video presentations.

Blackboard 9.1 Supported Browsers and Operating Systems

Release 9.1 SP6 Supported Browsers & Operating Systems

Blackboard Collaborate - Web Conferencing

Click Here to test your browser.

Software Download

Software Download provides free software you may need in order to use Blackboard.


Document Actions